Before installing the toolbox

Before installing the toolbox, QGIS version 3.10.3 or higher needs to be installed on your computer.

Download QGIS

To install the plugin, first install QGIS 3.10.3+ following the below steps:

  1. Choose either 32 or 64 bit version

    You have the option of installing a 32-bit or 64-bit version of QGIS. To know which version to install, check which type of operating system you have following the below instructions. If you are unsure which you need, try downloading the 64 bit version first. If that version doesn’t work properly, un-install it and then install the 32 bit version.

    • Windows 8 or Windows 10

      • From the “Start” screen, type “This PC”.

      • Right click (or tap and hold) “This PC”, and click “Properties”.

    • Windows 7, or Vista

      • Open “System” by clicking the “Start” button , right-clicking “Computer”, and then clicking “Properties”.

      • Under System, you can view the system type.

    • Mac: Click the Apple icon in the top left and select “About this Mac”.

  2. After determining whether you need the 32 or 64 bit version, download the appropriate installer:

Install QGIS

Once the installer is downloaded from the website, it needs to be run (double click on it). Select the Default settings for all options.

Installing older versions of QGIS

Older versions of QGIS can be accessed at the below links. We recommend the latest version of QGIS (see instructions above) but the below links might be useful if you have a specific need for accessing an older version of the Trends.Earth plugin (for example the QGIS2 version of the plugin).